File diff d58de74e1d44 → 33d3f301a3d6
setup.py
Show inline comments
 
# -*- coding: utf-8; -*-
 
################################################################################
 
#
 
#  sqlalchemy-pervasive -- SQLAlchemy Dialect for Pervasive PSQL
 
#  Copyright © 2013-2018 Sacramento Natural Foods Co-op, Inc
 
#  Copyright © 2013-2021 Sacramento Natural Foods Co-op, Inc
 
#
 
#  This file is part of sqlalchemy-pervasive.
 
#
 
#  sqlalchemy-pervasive is free software: you can redistribute it and/or modify
 
#  it under the terms of the GNU General Public License as published by the
 
#  Free Software Foundation, either version 3 of the License, or (at your
 
@@ -18,14 +18,12 @@
 
#
 
#  You should have received a copy of the GNU General Public License along with
 
#  sqlalchemy-pervasive.  If not, see <http://www.gnu.org/licenses/>.
 
#
 
################################################################################
 

	
 
from __future__ import unicode_literals, absolute_import
 

	
 
import os.path
 
from setuptools import setup, find_packages
 

	
 

	
 
here = os.path.abspath(os.path.dirname(__file__))
 
exec(open(os.path.join(here, 'sqlalchemy_pervasive', '_version.py')).read())
 
@@ -76,22 +74,21 @@ setup(
 
    url = 'https://github.com/SacNaturalFoods/sqlalchemy-pervasive',
 
    license = "GNU GPL v3",
 
    description = "SQLAlchemy Dialect for Pervasive PSQL",
 
    long_description = README + '\n\n' +  CHANGES,
 

	
 
    classifiers = [
 
        'Development Status :: 3 - Alpha',
 
        'Development Status :: 5 - Production/Stable',
 
        'Intended Audience :: Developers',
 
        'License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)',
 
        'Natural Language :: English',
 
        'Operating System :: OS Independent',
 
        'Programming Language :: Python',
 
        'Programming Language :: Python :: 2.6',
 
        'Programming Language :: Python :: 2.7',
 
        'Programming Language :: Python :: 3',
 
        'Topic :: Software Development :: Libraries :: Python Modules',
 
        ],
 
    ],
 

	
 
    install_requires = requires,
 
    packages = find_packages(exclude=['tests']),
 
    include_package_data = True,
 

	
 
    entry_points = """